Ergebnis 1 bis 23 von 23

Thema: XAMPP - Port 80/Apache startet nicht

  1. #1

    Standard XAMPP - Port 80/Apache startet nicht

    Guten Abend

    Also ich wollte mir anfangen php anzueignen und habe mir XAMPP runtergeladen. Leider kommt beim Control-Fenster, dass Apache im Status "stopped" und nicht "Running" wie es eigentlich sein sollte. Da die xampp-portcheck.exe fehlt kann ich auch leider nicht nachgucken wer oder was eventuell mein Port 80 belegt. Freigeben über eine Regel bei der Windows Firewall hat auch nicht geholfen.

    Bitte um Hilfe :/

    Gruss
    Erestor

  2. #2
    Master Gunnery Sergeant Avatar von Anne
    Registriert seit
    27.01.2010
    Beiträge
    2.512

    Standard

    Was für ein Betriebssystem hast du denn?
    "Wenn man tot ist, ist das für einen selbst nicht schlimm, weil man ja tot ist. Schlimm ist es aber für die Anderen....
    Genauso ist es übrigens wenn man doof ist.
    "




  3. #3
    Sergeant
    Themenstarter

    Registriert seit
    10.03.2008
    Beiträge
    53

    Standard

    Windows 7 - Professional

  4. #4

    Standard

    In welchem Ordener ist Apache installiert?
    Gruß OBs

    ---------

  5. #5
    Major General Avatar von SethOS
    Registriert seit
    17.02.2006
    Beiträge
    18.577

    Standard

    Hast Du Skype installiert? Per Default Belegt Skype den Port 80

    Also entweder Skype oder den Apache umkonfigurieren (falls Du überhaupt Skype installiert hast).
    "Prophet!" said I, "thing of evil - prophet still, if bird or devil!
    By that Heaven that bends above us - by that God we both adore -
    Tell this soul with sorrow laden if, within the distant Aidenn,
    It shall clasp a sainted maiden whom the angels name Lenore -
    Clasp a rare and radiant maiden whom the angels name Lenore."
    Quoth the Raven, "Nevermore."

    From "The Raven" by Edgar Allan Poe

  6. #6
    Sergeant
    Themenstarter

    Registriert seit
    10.03.2008
    Beiträge
    53

    Standard

    Liegt direkt unterm Root also C:/xampp
    und Skype ist nicht installiert!

    Gibts nen guten Portchecker? weil der von xampp ist nicht dabei!

  7. #7
    Major General Avatar von SethOS
    Registriert seit
    17.02.2006
    Beiträge
    18.577

    Standard

    Ändere doch einfach den Port des Apache. Wahrscheinlich der schnellste Weg.
    "Prophet!" said I, "thing of evil - prophet still, if bird or devil!
    By that Heaven that bends above us - by that God we both adore -
    Tell this soul with sorrow laden if, within the distant Aidenn,
    It shall clasp a sainted maiden whom the angels name Lenore -
    Clasp a rare and radiant maiden whom the angels name Lenore."
    Quoth the Raven, "Nevermore."

    From "The Raven" by Edgar Allan Poe

  8. #8
    Sergeant
    Themenstarter

    Registriert seit
    10.03.2008
    Beiträge
    53

    Standard

    Wo mache ich das?

  9. #9
    Master Gunnery Sergeant Avatar von Anne
    Registriert seit
    27.01.2010
    Beiträge
    2.512

    Standard

    Lade dir das ganze doch nochmal hier als Installer runter mit Portcheck.exe.Und dann installiere das ganze mal mit Administratorrechten. Also Mausklick rechts ausführen als Administrator. Ansonsten prüfe mal ob die Dienste korrekt laufen. Lies dir auch die Faq nochmals durch.
    "Wenn man tot ist, ist das für einen selbst nicht schlimm, weil man ja tot ist. Schlimm ist es aber für die Anderen....
    Genauso ist es übrigens wenn man doof ist.
    "




  10. #10
    Major General Avatar von SethOS
    Registriert seit
    17.02.2006
    Beiträge
    18.577

    Standard

    Zitat Zitat von Erestor Beitrag anzeigen
    Wo mache ich das?
    Ist an sich leicht:
    [Installationspfad XAMPP]\apache\conf\httpd.conf

    Dort suchst Du nach dem Eintrag "Listen", welcher aktuell auf 80 stehen dürfte. Dies kannst Du dann einfach editieren. Vergiß danach den Neustart des Apache nicht.

    Was Du aber auch mal machen kannst ist nach einem Fehlversuch in das ErrorLog zu werfen oder alternativ mal die apache_start.bat aus der Dos-Box zu starten. Ich habe da noch einen skurilen Fehler im Hinterkopf, dass eine Visual-C++ Runtime fehlt...
    "Prophet!" said I, "thing of evil - prophet still, if bird or devil!
    By that Heaven that bends above us - by that God we both adore -
    Tell this soul with sorrow laden if, within the distant Aidenn,
    It shall clasp a sainted maiden whom the angels name Lenore -
    Clasp a rare and radiant maiden whom the angels name Lenore."
    Quoth the Raven, "Nevermore."

    From "The Raven" by Edgar Allan Poe

  11. #11
    Sergeant
    Themenstarter

    Registriert seit
    10.03.2008
    Beiträge
    53

    Standard

    @Anne: hab mir das genau da runtergeladen, einmal als Installer 2x als ZIP, war kein mal dabei..

    @SethOS: hab es geändert, funktioniert immer noch nicht, im Xampp log steht dann immer noch: "Busy.. / Apache started [Port 80]"
    Bei der apache_start.bat kommt nur dass Apache nicht gestartet werden konnte..

  12. #12
    Major General Avatar von SethOS
    Registriert seit
    17.02.2006
    Beiträge
    18.577

    Standard

    Hm, also laut Deiner Fehlermeldung hast Du den Port noch nicht umgestellt. Dort steht immer noch Port 80.
    "Prophet!" said I, "thing of evil - prophet still, if bird or devil!
    By that Heaven that bends above us - by that God we both adore -
    Tell this soul with sorrow laden if, within the distant Aidenn,
    It shall clasp a sainted maiden whom the angels name Lenore -
    Clasp a rare and radiant maiden whom the angels name Lenore."
    Quoth the Raven, "Nevermore."

    From "The Raven" by Edgar Allan Poe

  13. #13
    Sergeant
    Themenstarter

    Registriert seit
    10.03.2008
    Beiträge
    53

    Standard

    Habe es nach Listen 49152 umgestellt

    Edit: Vielleicht hilft es, wenn ich sage, dass der Port beim Portscan überhaupt nicht angezeigt wird. Hat es eventuell was mit der FritzBox! zu tun?

    Port 443 wird von PandoMediaBooster belegt

    Zusammengefasst nach 13 minutes:

    So! Ich habs geschafft. PandoMediaBooster hat bei mir den Port 443 belegt. Hab die PMB.exe über den Taskmanager geschlossen und startet Apache auch!

    Danke für eure Hilfe!
    Geändert von Erestor (07.05.2012 um 13:48 Uhr)

  14. #14
    Major General Avatar von SethOS
    Registriert seit
    17.02.2006
    Beiträge
    18.577

    Standard

    Welchen Portscanner hast Du denn benutzt? Die ganz hohen Ports werden per Default meist nicht mehr gescannt, die muss man meist per Parameter hinzufügen.

    Naja, dann stell' doch auch mal den SSL Port im Apache um.
    "Prophet!" said I, "thing of evil - prophet still, if bird or devil!
    By that Heaven that bends above us - by that God we both adore -
    Tell this soul with sorrow laden if, within the distant Aidenn,
    It shall clasp a sainted maiden whom the angels name Lenore -
    Clasp a rare and radiant maiden whom the angels name Lenore."
    Quoth the Raven, "Nevermore."

    From "The Raven" by Edgar Allan Poe

  15. #15
    Sergeant
    Themenstarter

    Registriert seit
    10.03.2008
    Beiträge
    53

    Standard

    Portscan heisst der einfach weiss nicht genau, woher der jetzt nochmal war.
    Wie meinst du das mit dem SSL Port umstellen?

  16. #16
    Major General Avatar von SethOS
    Registriert seit
    17.02.2006
    Beiträge
    18.577

    Standard

    Naja, ich will in Richtung Portscanner auch eigentlich keine weiteren Anleitungen geben - das Problem ist ja mitlerweile auch gelöst. Wahrscheinlich hat dieser rudimentäre Scanner auch die hohen Ports ausgelassen.

    Du kannst nicht nur den http Port (80) ändern, sondern auch den https Port (443) ändern. Ich glaube in XAMPP geht dies via [Installationspfad XAMPP]\apache\conf\extra\httpd-ssl.conf.

    Ansich mußt Du nun nur überlegen, ob Du diesen MediaBooster brauchst und die Apache-Ports änderst, oder Du diesen Booster löschst (oder vielleicht dessen Port änderst).
    "Prophet!" said I, "thing of evil - prophet still, if bird or devil!
    By that Heaven that bends above us - by that God we both adore -
    Tell this soul with sorrow laden if, within the distant Aidenn,
    It shall clasp a sainted maiden whom the angels name Lenore -
    Clasp a rare and radiant maiden whom the angels name Lenore."
    Quoth the Raven, "Nevermore."

    From "The Raven" by Edgar Allan Poe

  17. #17
    Sergeant
    Themenstarter

    Registriert seit
    10.03.2008
    Beiträge
    53

    Standard

    Ich denke nicht dass ich ihn auf dem Laptop brauche, da er nur für p2p bei League of Legends notwendig ist.

    Vielen Dank!

  18. #18

    Standard

    Ich habe das gleiche Problem. Ich habe auch kein Skype installiert und den Media Booster auch nicht. Wenn ich htttpd-ssl.confg öffne erscheint nur eine Menge kryptischer Text was mache ich falsch?
    Vielen Dank, im Vorraus

  19. #19
    Private Avatar von Rosalinda
    Registriert seit
    10.09.2013
    Ort
    Berlin
    Beiträge
    6

    Standard

    Wenn ich mich recht erinner gab es ein Problem mit Windows 7 und den Benutzerberechtigungen. Hier muss eventuell etwas an dem Startkonto des Apache Dienstes gemacht werden. lg

  20. #20

    Standard

    Wird bei mir aber nicht viel ausmachen, ich habe nämlich Vista Bussines (64 Bit).

  21. #21
    Private
    Registriert seit
    17.12.2007
    Beiträge
    42

    Standard

    Auch wieder ein alter Thread, immer wenn ich Hardware kaufe schau ich hier mal rein

    Das hilft hier vlt nicht mit wamp aber beseitigt Kopfschmerzen mit PHP für später

    1. Virtualbox runterladen
    2. Ubuntu Server oder Debian iso runterladen (weil die schon LAMP haben) alternativ geht auch Fedora (die haben die Option auch) oder eine andere Anfängerfreundliche Distribution.
    3. Virtuelle Maschine anlegen, auf Netzwerkadapter in der Virtualbox Bridge Modus stellen (damit sie eine eigene IP bekommt vom Router).
    Gebt dem mind 512MB RAM, 1-2GB tuns auch.
    4. (Optional) Webmin oder Virtualmin drauf installieren um die vhosts managen zu können und Samba komfortabel konfigurieren zu können.
    5. Den Docroot (idR /var/www/ ) per Samba freigeben und im Hostsystem (Windows) als Netzlaufwerk einstellen.

    So ist das Windows sauber, es gibt keine Kollisionen bei den Ports und man kann die Arbeit die man sich gemacht hat auch auf einen anderen Rechner mitnehmen (USB Sticks sind ja groß genug heutzutage) und man lernt noch etwas über Linux.

  22. #22

    Ausrufezeichen

    Ich benutze Windows 7 Porfessional 64 Bit und habe auch dasselbe Problem.

    XAMPP ist installiert aber Apache startet nicht:

    18:47:08 [main] Initializing Control Panel
    18:47:08 [main] Windows Version: Windows 7 Professional SP1 64-bit
    18:47:08 [main] XAMPP Version: 1.8.3
    18:47:08 [main] Control Panel Version: 3.2.1 [ Compiled: May 7th 2013 ]
    18:47:08 [main] Running with Administrator rights - good!
    18:47:08 [main] XAMPP Installation Directory: "c:\xampp\"
    18:47:08 [main] Checking for prerequisites
    18:47:08 [main] All prerequisites found
    18:47:08 [main] Initializing Modules
    18:47:08 [Apache] Problem detected!
    18:47:08 [Apache] Port 80 in use by "Unable to open process" with PID 4!
    18:47:08 [Apache] Apache WILL NOT start without the configured ports free!
    18:47:08 [Apache] You need to uninstall/disable/reconfigure the blocking application
    18:47:08 [Apache] or reconfigure Apache and the Control Panel to listen on a different port
    18:47:08 [main] Starting Check-Timer
    18:47:08 [main] Control Panel Ready

    Weil Port 80 vom System verwendet wird, kann Apache nicht strarten.
    Vorerst habe ich den Port von Apache von 80 auf 8080 geändert. Somit wurde das Problem zwar teilweise gelöst— außer dass ich vor jedem URL 8080 hinzufügen musste — aber dann, als ich beim Wordpress ein Blog-Netzwerk einrichten wollte, musste ich den Port wiederum auf 80 ändern, da Wordpress die Einrichtung eines Blog-Netzwerkes sonst nicht akzeptiert. Also muss ich Port 80 auf jeden Fall zuerst freigeben.

    Die betreffende Dienste, die Port 80 gerade verwenden, sind diejenige, die vom HTTP-Dienst abhängig sind. Ich kann natürlich den HTTP-Dienst stoppen aber dann funktionieren viele andere abhängige Dienste wiederum nicht mehr. Also besteht eine bessere Lösung wahrscheinlich darin, dass man dem Dienst HTTP einen anderen Port zuweist. Meine Frage ist: Wie geht das? Wie gebe ich dem HTTP-Dienst einen anderen Port als 80?

    Ich würde mich überaus freuen, wenn mir jemand helfen würde.

    Vielen Dank bereits

    Liebe Grüße
    Leyyin.

  23. #23
    Lieutenant General Avatar von BigWhoop
    Registriert seit
    14.10.2006
    Ort
    Bielefeld
    Beiträge
    30.047

    Standard

    Was hast du denn überhaupt noch installiert was den port 80 dicht macht?
    2.00000000 + 2.000000000 = 3.999998456

    hwmartikel - XAMPP - Port 80/Apache startet nicht

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Ähnliche Themen

  1. 5-port oder 8-port Switch gesucht...
    Von Maverick64 im Forum Modem / Netzwerke allgemein
    Antworten: 10
    Letzter Beitrag: 19.01.2012, 02:50
  2. RDP-Port geändert - Verbindung nicht möglich
    Von obscurus gladius im Forum Windows
    Antworten: 0
    Letzter Beitrag: 19.09.2008, 11:29
  3. Antworten: 9
    Letzter Beitrag: 22.07.2008, 15:52
  4. [NSLU2] Apache will nicht starten
    Von sina im Forum Modem / Netzwerke allgemein
    Antworten: 36
    Letzter Beitrag: 08.06.2008, 22:44
  5. NSLU2 Port vom Web-interface auf 6666 geändert geht nur nicht mehr.
    Von Altec im Forum Modem / Netzwerke allgemein
    Antworten: 2
    Letzter Beitrag: 12.11.2007, 18:27

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •