Ergebnis 1 bis 14 von 14

Thema: Ubuntu Problem mit Samba automount

  1. #1
    Master Sergeant
    Registriert seit
    09.01.2005
    Beiträge
    883

    Standard Ubuntu Problem mit Samba automount

    Hallo,

    ich versuche die fstab so zu bearbeiten das mein Ubuntu die einzelnen Ordner meines Windows Home Server's automatisch mountet.

    Ich kriege allerdings einen Fehler.

    Hier mein Eintrag aus der fstab:
    //192.168.178.26/Arbeit /media/WHSArbeit smbfs username=Max,password=Geheim,uid=1000,nls=utf8,cod epage=unicode 0 0
    Und hier die Fehlermeldung wenn ich "sudo mount -a" eingebe:
    Warning: ignoring deprecated smbfs option 'codepage=unicode'
    Couldn't chdir to /media/WHSArbeit: No such file or directory
    Bin für jede Hilfe dankbar.
    Es sind nicht die Momente im Leben in denen du atmest die zählen, oh nein, es sind die Momente im Leben die dir den Atem nehmen

  2. #2
    Lieutenant General Avatar von BigWhoop
    Registriert seit
    14.10.2006
    Ort
    Bielefeld
    Beiträge
    30.046

    Standard

    also das codepage ding lässt du weg. Und den ordern /media/WHSArbeit erstellst du.

    dann kann noch nen: iocharset=utf8 rein und ein gid=1000

    und dein NLS löschst du raus.
    2.00000000 + 2.000000000 = 3.999998456

    hwmartikel - Ubuntu Problem mit Samba automount

  3. #3
    Master Sergeant
    Themenstarter

    Registriert seit
    09.01.2005
    Beiträge
    883

    Standard

    Danke für die Antwort.

    Die Zeile in der fstab sieht dann jetzt wie folgt aus:
    //192.168.178.26/Arbeit /media/WHSArbeit smbfs username=Max,password=Geheim,uid=1000,iocharset=ut f8,gid=1000 0 0
    Fehlermeldung ist jetzt folgende:
    mount error(13): Permission denied
    Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
    Was mache ich jetzt falsch? =)

    Edit: Die Lücke bei "utf8" wird hier zwar angezeigt ist aber nicht in der fstab. Und gibt es eigentlich eine Möglichkeit das man nicht jeden Ordner einzeln Mounten muss, Sonder direkt den "ganzen Server"?
    Es sind nicht die Momente im Leben in denen du atmest die zählen, oh nein, es sind die Momente im Leben die dir den Atem nehmen

  4. #4
    Moderator Avatar von Black & White
    Registriert seit
    18.06.2009
    Beiträge
    38.515

    Standard

    ,iocharset=ut f8
    warum ist da ein leerzeichen dazwischen?

    une evtl hilft dir das: Cifs "mount error 13 = Permission denied" CIFS SUCKS
    Mit freundlichen Grüßen
    Ihr Moderatorenteam

    signaturbild mod - Ubuntu Problem mit Samba automount
    Kontakt: Kundenbetreuung | Logistik | Reklamation | Technik | Service Level Gold | Infocenter | Highlights

    Sent from my fingers using my brain, both arms and my keyboard und NEIN, ich will nicht wissen, was irgendwer zum posten nutzt! solche msg darf man gern deaktivieren, danke!
    ...und nein, ich bin kein Mitarbeiter der Mindfactory AG!

  5. #5
    Master Sergeant
    Themenstarter

    Registriert seit
    09.01.2005
    Beiträge
    883

    Standard

    Zitat Zitat von Black & White Beitrag anzeigen
    warum ist da ein leerzeichen dazwischen?
    Siehe mein Edit. In der eigentlichen Datei ist kein Leerzeichen. Keine Ahnung warum das im Quote angezeigt wird.

    //192.168.178.26/Arbeit /media/WHSArbeit smbfs username=Arbeitsgruppe/Max,password=Geheim,uid=1000,iocharset=ut f8,gid=1000 0 0
    Führt leider auch nicht zu gewünschtem Ergebnis. Fehlermeldung bleibt die gleiche.
    Es sind nicht die Momente im Leben in denen du atmest die zählen, oh nein, es sind die Momente im Leben die dir den Atem nehmen

  6. #6
    Lieutenant General Avatar von BigWhoop
    Registriert seit
    14.10.2006
    Ort
    Bielefeld
    Beiträge
    30.046

    Standard

    schreibst du auch nen sudo davor wenn du es selbst testest?
    2.00000000 + 2.000000000 = 3.999998456

    hwmartikel - Ubuntu Problem mit Samba automount

  7. #7
    Master Sergeant
    Themenstarter

    Registriert seit
    09.01.2005
    Beiträge
    883

    Standard

    Zitat Zitat von BigWhoop Beitrag anzeigen
    schreibst du auch nen sudo davor wenn du es selbst testest?
    Siehe erster Post. Das tue ich. Hab auch nochmal alles auf Fehler geprüft und auch mit anderem Nutzernamen Passwort.

    Leider kein Erfolg.
    Es sind nicht die Momente im Leben in denen du atmest die zählen, oh nein, es sind die Momente im Leben die dir den Atem nehmen

  8. #8
    Lieutenant General Avatar von BigWhoop
    Registriert seit
    14.10.2006
    Ort
    Bielefeld
    Beiträge
    30.046

    Standard

    Arbeitsgruppe ist aber keine domain. DA muss dann der computername hin. und das PW ist wirklich Geheim?
    2.00000000 + 2.000000000 = 3.999998456

    hwmartikel - Ubuntu Problem mit Samba automount

  9. #9
    Master Sergeant
    Themenstarter

    Registriert seit
    09.01.2005
    Beiträge
    883

    Standard

    Zitat Zitat von BigWhoop Beitrag anzeigen
    Arbeitsgruppe ist aber keine domain. DA muss dann der computername hin. und das PW ist wirklich Geheim?
    Habe es mit dem Computernamen probiert. Leider kein Erfolg.

    Das Passwort ist nicht "Geheim" das dient hier lediglich als Platzhalter.

    Habe mittlerweile alles gefühlt 1000mal auf Fehler/Vertipper überprüft, Nichts. Auch das smbfs Paket hab ich mal neuinstalliert.

    Ich bin Linuxneuling. d.h. wenn es etwas ganz grundlegedes gibt, das gemacht werden muss, damit das ganze funktioniert. Erwähnt es ruhig. Nicht das ihr etwas voraussetzt was nicht der Fall ist
    Es sind nicht die Momente im Leben in denen du atmest die zählen, oh nein, es sind die Momente im Leben die dir den Atem nehmen

  10. #10
    Lieutenant General Avatar von BigWhoop
    Registriert seit
    14.10.2006
    Ort
    Bielefeld
    Beiträge
    30.046

    Standard

    na wenn es nicht das PW ist könnte der Fehler ja auch dort liegen. Wähl mal ein anderes. vorzugweise ohne Sonderzeichen oder umlaute.
    2.00000000 + 2.000000000 = 3.999998456

    hwmartikel - Ubuntu Problem mit Samba automount

  11. #11
    Master Sergeant
    Themenstarter

    Registriert seit
    09.01.2005
    Beiträge
    883

    Standard

    Zitat Zitat von BigWhoop Beitrag anzeigen
    na wenn es nicht das PW ist könnte der Fehler ja auch dort liegen. Wähl mal ein anderes. vorzugweise ohne Sonderzeichen oder umlaute.
    Nachdem ich jetzt ein PW nur aus Buchstaben/Zahlen gewählt habe funktioniert das ganze

    Danke soweit =)

    Nächster Schritt wäre das Kennwort irgendwie verschlüsselt zu hinterlegen.
    Und ist es möglich gleich den "ganzen Server" also nicht jeden Ordner einzeln einzubinden?
    Es sind nicht die Momente im Leben in denen du atmest die zählen, oh nein, es sind die Momente im Leben die dir den Atem nehmen

  12. #12
    Lieutenant General Avatar von BigWhoop
    Registriert seit
    14.10.2006
    Ort
    Bielefeld
    Beiträge
    30.046

    Standard

    Tzjaja die Linux anfänger...wenn man hilfe möchte sollte man schon alles schreiben

    du kannst einfach überordner freigeben..aber da du es mounten musst ist natürlich dieser schritt dann notwendig.
    2.00000000 + 2.000000000 = 3.999998456

    hwmartikel - Ubuntu Problem mit Samba automount

  13. #13
    Master Sergeant
    Themenstarter

    Registriert seit
    09.01.2005
    Beiträge
    883

    Standard

    Zitat Zitat von BigWhoop Beitrag anzeigen
    Tzjaja die Linux anfänger...wenn man hilfe möchte sollte man schon alles schreiben
    Ich bin da eher ein Freund von step by step damit man auch begreift was man tut. Deswegen habe ich auch erst damit angefangen eine der Windowspartitionen zu automounten.

    Zitat Zitat von BigWhoop Beitrag anzeigen
    du kannst einfach überordner freigeben..aber da du es mounten musst ist natürlich dieser schritt dann notwendig.
    Das verstehe ich nicht. In der Windowswelt währe der "Überordner" der Name des Computers.
    Es sind nicht die Momente im Leben in denen du atmest die zählen, oh nein, es sind die Momente im Leben die dir den Atem nehmen

  14. #14
    Lieutenant General Avatar von BigWhoop
    Registriert seit
    14.10.2006
    Ort
    Bielefeld
    Beiträge
    30.046

    Standard

    nein du kannst keine computer frei geben das unterste ist der root ordner.

    in diesem fall dann wohl c:\ oder d:\ etc

    Mit "alles schreiben" meine ich korrekte sachen. Ich gehe ja auch nicht mit einem Opel Auto in der Werkstatt zur diagnose um dann mit meinem VW vor zu fahren bei der reperatur. Wir hätten sofort gewusst was schief läuft wenn du da nicht sachen austauschen würdest.
    2.00000000 + 2.000000000 = 3.999998456

    hwmartikel - Ubuntu Problem mit Samba automount

Aktive Benutzer

Aktive Benutzer

Aktive Benutzer in diesem Thema: 1 (Registrierte Benutzer: 0, Gäste: 1)

Ähnliche Themen

  1. Ubuntu 8.10 erschienen
    Von Gargi im Forum Linux & Mac OS
    Antworten: 2
    Letzter Beitrag: 02.11.2008, 16:50
  2. Ubuntu auf dem EeePC
    Von Gargi im Forum Note- & Netbooks
    Antworten: 0
    Letzter Beitrag: 20.04.2008, 00:26
  3. Problem mit Mikrofon und Onboard Sound
    Von fischauge im Forum Webcams, Sound & Multimedia
    Antworten: 7
    Letzter Beitrag: 30.08.2007, 00:29
  4. Laptop WLAN findet Access point nicht
    Von Reiwill im Forum WLAN
    Antworten: 3
    Letzter Beitrag: 05.04.2007, 10:05
  5. Ubuntu zwischen Himmel und Hölle
    Von Gargi im Forum Linux & Mac OS
    Antworten: 6
    Letzter Beitrag: 11.02.2007, 21:22

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •